Categories
Uncategorized

OSX Mavericks upgrade and PhpStorm problems

I upgraded my work laptop’s OS to Mavericks (finally). Started the upgrade yesterday when going home and when I went back to work today, PhpStorm stopped working. I got no errors, no warnings, nothing. It didn’t even give me an indication stating that it was trying to open PhpStorm.

So, like any sensible person I tried opening it through the command line and that’s when I got this error:

LSOpenURLsWithRole() failed with error -10658 for the file /Applications/PhpStorm.app.

So, I tried to run the executable for PhpStorm directly like so:

 /Applications/PhpStorm.app/Contents/MacOS/phpstorm 

It told me Java runtime is missing and it is requesting that it be installed. After that, if you cycle through the windows you should see an alert asking you if you want to install Java 6. Hit yes, and you should be good to go.

If you don’t see the alert, restart your machine and you will see it as soon as you login. Or, you can also just go to sun’s website and install it.