Categories
Uncategorized

Missing package errors after upgrading Go

Very recently, I upgraded Go from 1.11 to 1.12 and all hell broke lose. I kept getting errors of missing packages in golang.org/x/tools , etc .

The solution was to re-install Go. This can be done easily on OSX with

brew remove go --ignore-dependencies

Leave a Reply

Your email address will not be published. Required fields are marked *